Requirements

If you want to use SMSPassword in your own infrastructure, please check the requirements below.

Requirements

  • .NET Framework 4.0 or newer
  • Active Directory
  • Radius capable client device, a Radius client, like a Citrix Netscaler, VMware Horizon, Cisco ASA, etc
  • A domain joined server to install the service software. Windows server 2008,2012 or 2016.
  • Virtual installation fully supported, Hyper-V,VMWare,XenServer or Azure.
  • A domain administrator account
  • Internal or external SMS dispatcher (SMSPassword A100 SMS dispatcher)
  • For redundant setups; A load balancer like, Citrix Netscaler 9.2 or newer.

 

The SMSPassword service can only be installed once per Windows installation. Running the service twice on one machine is not supported.

SMSPassword is tested to work with:

  • Citrix Netscaler
  • VMWare Horizon
  • Cisco
  • Juniper
  • F5
  • Barracuda
  • Check point

SMSPassword works with any radius client that implements the challenge, response protocol correctly.

 

 

palo-alto-logoCisco_logo_2006juniper-logo-png F5netscalerview_client_icon